use strict;
my $str = 'Word\\\\User MRU\\\\LiveId_7A5166EB69B271A475B25410BA565F1A63A6FD1BD8CF0F780A344EC2B287CCC1\\\\Plac‌​‌​e MRU';
my $regex = qr/.*LiveId_(\w+).*/p;
my $subst = 'This the LiveId string: \\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";