# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(49)\(?([0-9]{3})[\)\s\\/]?([0-9]{8})/\1\2\3/gm;t' <<< "+4917112345678
004917112345678
+49171/12345678
0049171 12345678
004312345678"