re = /(49)\(?([0-9]{3})[\)\s\/]?([0-9]{8})/m
str = '+4917112345678
004917112345678
+49171/12345678
0049171 12345678
004312345678'
subst = '\\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result