import re
regex = re.compile(r"(49)\(?([0-9]{3})[\)\s\/]?([0-9]{8})", flags=re.MULTILINE)
test_str = ("+4917112345678\n"
"004917112345678\n"
"+49171/12345678\n"
"0049171 12345678\n"
"004312345678")
subst = "\\1\\2\\3"
result = regex.sub(subst, test_str)
if result:
print(result)