// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(49)\(?([0-9]{3})[\)\s\/]?([0-9]{8})").unwrap();
let string = "+4917112345678
004917112345678
+49171/12345678
0049171 12345678
004312345678";
let substitution = "\\1\\2\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}