const regex = /(49)\(?([0-9]{3})[\)\s\/]?([0-9]{8})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(49)\\(?([0-9]{3})[\\)\\s\\\/]?([0-9]{8})', 'gm')
const str = `+4917112345678
004917112345678
+49171/12345678
0049171 12345678
004312345678`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);