use strict;
my $str = '+4917112345678
004917112345678
+49171/12345678
0049171 12345678
004312345678';
my $regex = qr/(49)\(?([0-9]{3})[\)\s\/]?([0-9]{8})/mp;
my $subst = '\\1\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";