#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(49)\(?([0-9]{3})[\)\s\/]?([0-9]{8})"
Local $sString = "+4917112345678" & @CRLF & _
"004917112345678" & @CRLF & _
"+49171/12345678" & @CRLF & _
"0049171 12345678" & @CRLF & _
"004312345678"
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)