using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(49)\(?([0-9]{3})[\)\s\/]?([0-9]{8})";
string substitution = @"\1\2\3";
string input = @"+4917112345678
004917112345678
+49171/12345678
0049171 12345678
004312345678";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}