# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ *(\b\w+)\.? *(?=.*\b\1)//g;t' <<< " bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 "