import Foundation
let pattern = #" *(\b\w+)\.? *(?=.*\b\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)