$re = '/ *(\b\w+)\.? *(?=.*\b\1)/';
$str = ' bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;