import re
regex = re.compile(r" *(\b\w+)\.? *(?=.*\b\1)")
test_str = " bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)