use strict;
my $str = ' bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 ';
my $regex = qr/ *(\b\w+)\.? *(?=.*\b\1)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";