re = / *(\b\w+)\.? *(?=.*\b\1)/
str = ' bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result