using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *(\b\w+)\.? *(?=.*\b\1)";
string substitution = @"";
string input = @" bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}