# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\s*<(?!\/))([^<]+)>(?=[^<]+\n)((?:(?!<\/\2>)[\s\S])*?)(?=\n *<)(?![^>]*<\/\2>)/$1$2>$3\n$1\/$2>/gm;t' <<< "<p>
string
<b>
bold
</b>
<em>italic string</em>
<b>
also(bold)
</b>
</p>"