#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*<(?!/))([^<]+)>(?=[^<]+\n)((?:(?!</\2>)[\s\S])*?)(?=\n *<)(?![^>]*</\2>)"
Local $sString = "<p>" & @CRLF & _
" string" & @CRLF & _
" <b>" & @CRLF & _
" bold" & @CRLF & _
" </b>" & @CRLF & _
" <em>italic string</em>" & @CRLF & _
" <b>" & @CRLF & _
" also(bold)" & @CRLF & _
" </b>" & @CRLF & _
" </p>"
Local $sSubst = "$1$2>$3\n$1/$2>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)