# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*<(?!/))([^<]+)>(?=[^<]+\n)((?:(?!</\2>)[\s\S])*?)(?=\n *<)(?![^>]*</\2>)"
test_str = ("<p>\n"
" string\n"
" <b>\n"
" bold\n"
" </b>\n"
" <em>italic string</em>\n"
" <b>\n"
" also(bold)\n"
" </b>\n"
" </p>")
subst = "$1$2>$3\\n$1/$2>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.