const regex = new RegExp('^(\\s*<(?!/))([^<]+)>(?=[^<]+\\n)((?:(?!</\\2>)[\\s\\S])*?)(?=\\n *<)(?![^>]*</\\2>)', 'gm')
const str = `<p>
string
<b>
bold
</b>
<em>italic string</em>
<b>
also(bold)
</b>
</p>`;
const subst = `$1$2>$3\n$1/$2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);