use strict;
my $str = '<p>
string
<b>
bold
</b>
<em>italic string</em>
<b>
also(bold)
</b>
</p>';
my $regex = qr~^(\s*<(?!/))([^<]+)>(?=[^<]+\n)((?:(?!</\2>)[\s\S])*?)(?=\n *<)(?![^>]*</\2>)~mp;
my $subst = '$1$2>$3\\n$1/$2>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";