import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*<(?!/))([^<]+)>(?=[^<]+\\n)((?:(?!</\\2>)[\\s\\S])*?)(?=\\n *<)(?![^>]*</\\2>)";
final String string = "<p>\n"
+ " string\n"
+ " <b>\n"
+ " bold\n"
+ " </b>\n"
+ " <em>italic string</em>\n"
+ " <b>\n"
+ " also(bold)\n"
+ " </b>\n"
+ " </p>";
final String subst = "$1$2>$3\\n$1/$2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}