# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<td([^>]*)>\s*((?:.(?!<\/td>))+\s*)\s*<\?php audioButton\("([^"]*)\/.+?",".*?"\);.*?\?>.*?<\/td>/<td$1>$2<?php audioButton("$3\/cat", "cat");?><\/td>/g;t' <<< "<td class=\"danish\">kat
<?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>
<td class=\"danish\">kat
<?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>
<td class=\"danish\">kat</td>
<td><?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>
<td class=\"danish\">kat
<?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>"