use strict;
my $str = '<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat</td>
<td><?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>';
my $regex = qr~<td([^>]*)>\s*((?:.(?!</td>))+\s*)\s*<\?php audioButton\("([^"]*)/.+?",".*?"\);.*?\?>.*?</td>~p;
my $subst = '<td$1>$2<?php audioButton("$3/cat", "cat");?></td>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";