const regex = new RegExp('<td([^>]*)>\\s*((?:.(?!</td>))+\\s*)\\s*<\\?php audioButton\\("([^"]*)/.+?",".*?"\\);.*?\\?>.*?</td>', 'g')
const str = `<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat</td>
<td><?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>`;
const subst = `<td$1>$2<?php audioButton("$3/cat", "cat");?></td>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);