import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td([^>]*)>\\s*((?:.(?!</td>))+\\s*)\\s*<\\?php audioButton\\(\"([^\"]*)/.+?\",\".*?\"\\);.*?\\?>.*?</td>";
final String string = "<td class=\"danish\">kat\n"
+ "<?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>\n\n"
+ "<td class=\"danish\">kat\n"
+ "<?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>\n\n"
+ "<td class=\"danish\">kat</td>\n"
+ "<td><?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>\n\n"
+ "<td class=\"danish\">kat\n"
+ "<?php audioButton(\"../../audio/words/dog\",\"dog\");?></td>";
final String subst = "<td$1>$2<?php audioButton(\"$3/cat\", \"cat\");?></td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}