using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td([^>]*)>\s*((?:.(?!</td>))+\s*)\s*<\?php audioButton\(""([^""]*)/.+?"","".*?""\);.*?\?>.*?</td>";
string substitution = @"<td$1>$2<?php audioButton(""$3/cat"", ""cat"");?></td>";
string input = @"<td class=""danish"">kat
<?php audioButton(""../../audio/words/dog"",""dog"");?></td>
<td class=""danish"">kat
<?php audioButton(""../../audio/words/dog"",""dog"");?></td>
<td class=""danish"">kat</td>
<td><?php audioButton(""../../audio/words/dog"",""dog"");?></td>
<td class=""danish"">kat
<?php audioButton(""../../audio/words/dog"",""dog"");?></td>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}