#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^|#)9\|(4[,#]|([\d]+,)+4[,#])"
Local $sString = "7|1#9|1,5,7#10|2,4,51#" & @CRLF & _
"7|1#9|1,4,5#10|1,3,38#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")