import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|#)9\\|(4[,#]|([\\d]+,)+4[,#])";
final String string = "7|1#9|1,5,7#10|2,4,51#\n"
+ "7|1#9|1,4,5#10|1,3,38#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}