// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|#)9\|(4[,#]|([\d]+,)+4[,#])").unwrap();
let string = "7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}