const regex = /(^|#)9\|(4[,#]|([\d]+,)+4[,#])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|#)9\\|(4[,#]|([\\d]+,)+4[,#])', '')
const str = `7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}