using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|#)9\|(4[,#]|([\d]+,)+4[,#])";
string input = @"7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}