import Foundation
let pattern = ##"(^|#)9\|(4[,#]|([\d]+,)+4[,#])"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}