use strict;
my $str = '7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#';
my $regex = qr/(^|#)9\|(4[,#]|([\d]+,)+4[,#])/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}