import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+):";
final String string = "{ query: { and: [ { and: [ { _t: \"Manifest\" }, { or: [ { and: [ { _i: { gt: \"53b2616fe4b028359ac3fea4\" } } ] } ] }, { _s: \"active\" } ] }, { ENu_v: { elemMatch: { EOJ_v: { in: [ \"*\", \"Production\", \"QA \" ] } } } } ] }, orderby: { _i: 1 } }";
final String subst = "\"\\1\":";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}