# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/="([^"]*){{(.*?)}}([^"]*?)"/="\1{{\2}}\3"/gmi;t' <<< "<a href=\"{{ \"<Test>\" }}\"></a>
<a href=\"{{ \"<Test>\" }}?subject=x\" test=\"tel:{{ lalala }}\">
<a href=\"{{ \"<Test>\" }}?subject=x\"\">
<a href=\"mailto:{{ Test }}?subject=x\" test=\"tel:{{ lalala }}\">
"