package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)="([^"]*){{(.*?)}}([^"]*?)"`)
var str = `<a href="{{ "<Test>" }}"></a>
<a href="{{ "<Test>" }}?subject=x" test="tel:{{ lalala }}">
<a href="{{ "<Test>" }}?subject=x"">
<a href="mailto:{{ Test }}?subject=x" test="tel:{{ lalala }}">
`
var substitution = "="\1{{\2}}\3""
fmt.Println(re.ReplaceAllString(str, substitution))
}