# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'="([^"]*){{(.*?)}}([^"]*?)"'
test_str = ("<a href=\"{{ \"<Test>\" }}\"></a>\n"
"<a href=\"{{ \"<Test>\" }}?subject=x\" test=\"tel:{{ lalala }}\">\n"
"<a href=\"{{ \"<Test>\" }}?subject=x\"\">\n"
"<a href=\"mailto:{{ Test }}?subject=x\" test=\"tel:{{ lalala }}\">\n")
subst = "=\"\\1{{\\2}}\\3\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.