re = /="([^"]*){{(.*?)}}([^"]*?)"/mi
str = '<a href="{{ "<Test>" }}"></a>
<a href="{{ "<Test>" }}?subject=x" test="tel:{{ lalala }}">
<a href="{{ "<Test>" }}?subject=x"">
<a href="mailto:{{ Test }}?subject=x" test="tel:{{ lalala }}">
'
subst = '="\\1{{\\2}}\\3"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result