using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=""([^""]*){{(.*?)}}([^""]*?)""";
string substitution = @"=""\1{{\2}}\3""";
string input = @"<a href=""{{ ""<Test>"" }}""></a>
<a href=""{{ ""<Test>"" }}?subject=x"" test=""tel:{{ lalala }}"">
<a href=""{{ ""<Test>"" }}?subject=x"">
<a href=""mailto:{{ Test }}?subject=x"" test=""tel:{{ lalala }}"">
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}