$re = '/="([^"]*){{(.*?)}}([^"]*?)"/mi';
$str = '<a href="{{ "<Test>" }}"></a>
<a href="{{ "<Test>" }}?subject=x" test="tel:{{ lalala }}">
<a href="{{ "<Test>" }}?subject=x"">
<a href="mailto:{{ Test }}?subject=x" test="tel:{{ lalala }}">
';
$subst = "=\"\1{{\2}}\3\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;