use strict;
my $str = '<a href="{{ "<Test>" }}"></a>
<a href="{{ "<Test>" }}?subject=x" test="tel:{{ lalala }}">
<a href="{{ "<Test>" }}?subject=x"">
<a href="mailto:{{ Test }}?subject=x" test="tel:{{ lalala }}">
';
my $regex = qr/="([^"]*){{(.*?)}}([^"]*?)"/mip;
my $subst = '="\\1{{\\2}}\\3"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";