package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:,\d+)*(?:\.\d|\.\d\d)?$`)
var str = `1
1.0
1.00
100.00
1,000.00
1000.00
111,000.00
111000.00
999,999,999.00
999,999,999,999.00
,1.00
1.
1,,00.00
1.000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}