use strict;
my $str = '1
1.0
1.00
100.00
1,000.00
1000.00
111,000.00
111000.00
999,999,999.00
999,999,999,999.00
,1.00
1.
1,,00.00
1.000';
my $regex = qr/^\d+(?:,\d+)*(?:\.\d|\.\d\d)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}