import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:,\\d+)*(?:\\.\\d|\\.\\d\\d)?$";
final String string = "1\n"
+ "1.0\n"
+ "1.00\n"
+ "100.00\n"
+ "1,000.00\n"
+ "1000.00\n"
+ "111,000.00\n"
+ "111000.00\n"
+ "999,999,999.00\n"
+ "999,999,999,999.00\n\n"
+ ",1.00\n"
+ "1.\n"
+ "1,,00.00\n"
+ "1.000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}