import re
regex = re.compile(r"^\d+(?:,\d+)*(?:\.\d|\.\d\d)?$", flags=re.MULTILINE)
test_str = ("1\n"
"1.0\n"
"1.00\n"
"100.00\n"
"1,000.00\n"
"1000.00\n"
"111,000.00\n"
"111000.00\n"
"999,999,999.00\n"
"999,999,999,999.00\n\n"
",1.00\n"
"1.\n"
"1,,00.00\n"
"1.000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")