$re = '/^\d+(?:,\d+)*(?:\.\d|\.\d\d)?$/m';
$str = '1
1.0
1.00
100.00
1,000.00
1000.00
111,000.00
111000.00
999,999,999.00
999,999,999,999.00
,1.00
1.
1,,00.00
1.000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);