const regex = new RegExp('^\\d+(?:,\\d+)*(?:\\.\\d|\\.\\d\\d)?$', 'gm')
const str = `1
1.0
1.00
100.00
1,000.00
1000.00
111,000.00
111000.00
999,999,999.00
999,999,999,999.00
,1.00
1.
1,,00.00
1.000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}