using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z]{3}, ([0-9]{1,2}) ([a-zA-Z]{3}) ([0-9]{4}) [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{3}";
string substitution = @"\2 \1, \3";
string input = @"Fri, 20 Apr 2012 12:00:00 EST";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}