package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z]{3}, ([0-9]{1,2}) ([a-zA-Z]{3}) ([0-9]{4}) [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{3}`)
var str = []byte(`Fri, 20 Apr 2012 12:00:00 EST`)
var substitution = []byte("\2 \1, \3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}